понедельник, 8 апреля 2013 г.

Dell PowerEdge 12G поколение и FreeBSD

По списку совместимости на 12 поколении dell (на базе Е5-2400, Е5-2600 например) работает FreeBSD 9.0+. Ниже по всей вероятности уже не заработает.
Основные узкие места:

  • RAID контроллеры H-серии (310, 710, 810) -- в основе LSi 2008 и 2208. 2008 работает и на 8 версии без проблем, 2208 пока проверить не доводилось. 2108 на 8 версии тоже работает, если что (вроде 700 серия была такая). Если что - есть системная утилита mfiutil, так как фирменная от LSi убога.
  • Сеть. Тут Broadcom BCM5720, и иногда всплывают проблемы вроде такой. Можно решить установкой отдельной интел-сетевой или убрать iDRAC (?)
http://engineering.wayfair.com/freebsd-9-0-on-dell-poweredge-12g-servers/

Также с сетью может быть такое:
bge0: link state changed to DOWN
bge0: link state changed to UP
bge0: link state changed to DOWN
bge0: link state changed to UP
десятки раз в секунду. Мне помогло в /boot/loader.conf
dev.bge.0.msi = 0
dev.bge.1.msi = 0

Кому-то может пригодиться ещё (при watchdog timeout - resetting)
hw.bge.allow_asf = 0
hw.pci.enable_msix = 0

Комментариев нет:

Отправить комментарий