среда, 8 июля 2015 г.

zabbix 2.4: The frontend does not match Zabbix database и далее

Запустили один не очень новый сервер с заббиксом и вылезло
Zabbix server will automatically upgrade the database
The frontend does not match Zabbix database. Current database version (mandatory/optional): 2020000/2020000. Required mandatory version: 2030000. Contact your system administrator.



Вообще, в 2.4 есть авто апдейт версии -- перезапускаем заббикс сервер и он автоматом обновляет базы, в логе это выглядит так
 11266:20150708:142500.748 using configuration file: /etc/zabbix/zabbix_server.conf
 11266:20150708:142500.792 current database version (mandatory/optional): 02020000/02020000
 11266:20150708:142500.792 required mandatory version: 02040000
 11266:20150708:142500.792 starting automatic database upgrade
 11266:20150708:142500.830 completed 0% of database upgrade
 11266:20150708:142500.888 completed 1% of database upgrade
...
 11266:20150708:142535.405 completed 100% of database upgrade
 11266:20150708:142535.405 database upgrade fully completed
 11266:20150708:142535.464 server #0 started [main process]
...

Но может выдать ошибку выше. В нашем случае -- в конфиге просто не был указан пароль, но в логе об этом было написано явно,
...
 11160:20150708:142416.911 [Z3001] connection to database 'zabbix' failed: [1045] Access denied for user 'zabbix'@'localhost' (using password: NO)
 11160:20150708:142416.911 database is down: reconnecting in 10 seconds
...
Указали пароль, перезапустили заббикс-сервер - пошло автообновление.

А вообще, не забывайте отслеживать изменения версий, те же шаблоны(templates) там иногда меняются, и не только они.

Комментариев нет:

Отправить комментарий